This is a draft cheat sheet. It is a work in progress and is not finished yet.
Configure DHCP Server
R1> enable |
R1# configure terminal |
R1(config)# int f0/0 |
R1(config-if)# ip address 10.1.1.2 255.255.255.0 |
R1(config-if)# no shut |
R1(config-if)# copy run start |
R1(config-if)# exit |
R1(config)# ip dhcp pool Development |
Development is the name of the pool
|
R1(dhcp-config)# network 10.1.1.0 255.255.255.0 |
this is the network IP addresses will be assigned from
|
dhcp server ip MUST be on the same subnet as router IP
|
|
Other Misc DHCP Configuration |
R1(dhcp-config)# default-router 10.1.1.2 |
|
R1(dhcp-config)# dns-server 10.1.1.2 |
this will normally be another server on your network
|
R1(config-if)# lease 7 |
choices are number of days or infinite
|
R1(dhcp-config)# ip dhcp excluded-address |
`this can be a range i.e. 10.1.1.5 10.1.1.11 |
|
R1(dhcp-config)# domain-name google.com |
R1(config-if)# option XX |
|
10.1.1.2 static assignment
|
R1(dhcp-config)# exit |
ip dhcp helper-address |
ip helper-address 192.168.1.245 [ip address of dhcp server] - ids the dhcp router and allows broadcast UDP traffic for dhcp assignment
int f0/0
ip helper-address 192.168.2.245
|
|
Verify DHCP
R1(config-dhcp)# show ip pool |
R1(config-dhcp)# show ip lease |
R1(config-dhcp)# show ip binding |
|
NAT
ip nat pool name [first IP] [last IP] net [subnet mask] |
defines the pool of public addresses to use |
ip nat inside source list [acl#] pool name overload |
enables PAT & specifies which ACL is being translated to which NAT pool |
ip nat inside |
identifies inside interface (int config) |
ip nat out |
ip nat outside |
ip nat in s st 192.168.1.10 209.165.200.18 |
configures static NAT mapping |
sh ip nat s |
show ip nat statistics |
show ip nat statistics |
show ip nat translations |
Configure DHCP Client
R1> enable |
R1# configure terminal |
R1(config)# int f0/0 |
R1(config)# mac-address aaaa.bbbb.cccc |
R1(config)# ip address dhcp |
R1(dhcp-config)# domain-name |
R1(config)# no shut |
|
R1(config-if)# ip dhcp cllient-id ascii PC2 |
allows a user friendly id to be assigned to a host
|
R1# show dhcp lease |
displays leasing information |
|