This is a draft cheat sheet. It is a work in progress and is not finished yet.
Factory Reset
R# sh run |
Check: hostname, interface, ip, duplex |
R# write erase |
[confirm] |
R# reload |
Continue with configuration dialog?: no |
Check results: |
# sh run
and # show start
|
Configuration |
R# config t |
R(config)# hostname [name] |
R(config)# interface GigabitEthernet[0/0] |
R(config-if)# ip address [IP] [mask] |
R(config-if)# duplex auto |
R(config-if)# speed auto |
R(config-if)# no shutdown |
R(config-if)#line con 0 |
R(config-line)# exec-timeout 30 0 |
R(config-line)#end |
R# copy run start |
|
R# sh ip route |
R# show run | section interface |
|
Disable interface FastEthernet 0/0 |
R(config)# interface fastEthernet 0/0 |
R(config-if)# shutdown |
|
|
Configure IP addresses on Router
R#config t |
R(config)# int f0/0 |
R(config-if)# ip address [IP] [mask] |
R(config-if)# no shut |
Verify routes have been added |
R# show ip route |
Verify the traffic path from PC to PC: |
C:\>ping [IP]
and C:\>tracert [IP]
|
Switch ports are not shutdown by default.
Static Routes
R# config t |
R(config)# ip route [Destination IP subnet] [Destination IP subnet mask] [next-hop IP] |
Verify connectivity by ping |
Verify the traffic path from PC to PC: |
C:\>ping [IP]
and C:\>tracert [IP]
|
|
Remove static routes |
R# config t |
R(config)# no ip route [Dest IP subnet] [Dest IP subnet mask] [next-hop IP] |
Summary Routes
R# config t |
R(config)# ip route [IP subnet] [mask subnet] [next hop IP] |
R(config)# end |
R# sh ip route |
Verify connectivity by ping |
Default Route and Load Balancing
R# config t |
R(config)# int f0/0 |
R(config-if)# ip add [IP] [mask] |
R(config-if)# no shut |
Ensure that each router has a route out to the internet |
R(config)# ip route 0.0.0.0 0.0.0.0 [next hop IP] |
Routing Protocol
Basic RIPv1 configuration + Enable RIPv2 |
R(config)# router rip |
R(config-router)# version 2 |
Enable RIPv2 |
R(config-router)# no auto-summary |
R(config-router)# network [ip subnet] |
R# show ip route |
Check that RIP routes have been added |
R#sh ip rip database |
View the RIP database |
|
Inject the default static route |
R(config)# router rip |
R(config-router)# default-information originate |
|
Debug the routing protocol updates |
R# debug ip rip |
R# undebug all |
Turn off all debugging |
|
Basic EIGRP configuration |
R(config)# router eigrp 100 |
// R(config-router)# network [IP subnet] |
R(config-router)# no auto-summary |
R(config-router)# network [IP] [mask] |
|
R(config)# no router eigrp 100 |
remove/ disable EIGRP |
|
R# sh ip eigrp neighbors |
|
Loopback configuration |
R(config)#interface loopback0 |
Adjacencies and Passive Interfaces
R# show ip eigrp neighbors |
Verify that R"x" has established EIGRP adjacencies with R"y" |
|
R(config-if)# router eigrp 100 |
Configure the loopback interface and the link as passive interfaces |
R(config-router)# passive-interface loopback0 |
R(config-router)# passive-interface fastethernet1/1 |
Basic OSPF configuration
R(config)# router ospf 1 |
R(config-router)# network [IP subnet] [wildcard mask] area 0 |
Ex: network 10.0.0.0 0.255.255.255 area 0 |
|
OSPF Verification |
R# sh run | section ospf |
show run | section ospf |
R# sh ip protocols |
show ip protocols |
R# show ip ospf interface brief |
show ip ospf interface brief |
R# show ip ospf neighbor |
show ip ospf neighbor |
R# show ip ospf database |
show ip ospf database |
R# show ip route |
show ip route |
|
Remove/ Disable OSPF |
R(config)# no router ospf 1 |
|
OSPF Router ID |
R# sh ip int brief |
Check Loopback or No Loopback |
R# show ip protocols |
|
R(config-router)# router ospf 1 |
Manually Configured |
R#(config-router)# router-id 2.2.2.2 |
R# clear ip ospf process |
R# show ip protocols |
|
Passive Interface Configuration |
R1(config-router)# router ospf 1 |
R1#(config-router)# passive-interface [loopback 0] |
ex2: R#(config-router)# passive-interface f2/0 |
|
R1(config-router)# router ospf 1 |
R1#(config-router)# passive-interface default |
set passive interface as the default |
R1#(config-router)# no passive-interface [f0/0] |
|
Default Route Injection |
R4(config)#ip route 0.0.0.0 0.0.0.0 203.0.113.2 |
R4(config)#router ospf 1 |
R4(config-router)#default-information originate |
---> R1#sh ip route |
Default Route Injection Verification |
|
OSPD Areas |
R(config)# router ospf 1 |
R(config-router)# network [IP subnet] [wildcard mask] area 0 |
|