Cheatography
https://cheatography.com
CCNA 200-301 Cheat Sheet for configuring different IOS devices
This is a draft cheat sheet. It is a work in progress and is not finished yet.
Day 4 - Basic Device Security / Commands
SW1(config)#banner motd $"enter welcome message"$ |
sets message of the day banner when entering an IOS device. |
SW1(config)#enable password "password" |
unencrypted password text will be applied and can be viewed in running-config. |
R1(config)#service password-encryption |
encrypts the current unencrypted passwords and featured inserted passwords with Type 7 encryption. |
SW1(config)#enable secret "password" |
encrypted password using MD5 hash. will take priority over unencrypted passwords. |
R1(config)#no ip domain-lookup |
disables DNS lookup from host and prevents miss-typed commands from being "translated". (CTRL+SHIFT+6) |
R1(conf-line)#logging synchronous |
prevents logging output from interrupting your command input. |
Router(config)#line vty 0 15 |
select ports 0-15 for SSH/Telnet virtual line. |
R1(config)#line console 0 |
selects the console port on the IOS device to make configuration changes. |
R1(config)#login |
activates a configured password that has been set for a remote connection such as Telnet or SSH. |
R1(config)#login local |
asks the user logging in to enter a username & password stored on the router. |
|
R1(config)#username username privilege 1-15 secret password |
STEP 1# sets up a username and password. |
R1(config)#line console 0 |
STEP 2# sets up a username and password. |
R1(config)#login local |
STEP 3# sets up a username and password. |
R1(config)#end |
STEP 4# sets up a username and password. |
|
SW1(config-if)#default interface g0/1 |
restores the default settings of the interface selected. |
|
Day 6 - Ethernet LAN Switching
SW1(config)#clear mac address-table dynamic |
manually removes the MAC address from the table. |
SW1(config)#clear mac address-table dynamic address MAC Address |
deletes specific entered mac address. |
SW1(config)#clear mac address-table dynamic interface interface |
deletes all mac address on an interface. |
|
Day 8 - IPv4 Addressing
R1(config-if)#ip address 192.168.1.1 255.255.255.0 |
sets the chosen interface with an IP address and Subnet Mask |
R1(config-if)#no shutdown |
enables the interface |
R1(config)#hostname R1 |
sets a hostname to a chosen network device. |
|
Day 9 - Switch Interfaces
SW1(config-if)#speed 10,100,1000 or auto |
sets the chosen interface speed settings. |
SW1(config)#duplex half,full or auto |
sets the chosen interface duplex settings. |
|
Day 11 - Static Routing
R1(config)#ip route | destination of the network's ip address | destination of the network's Subnet Mask | next hop router |
sets a static configured route of the next hop address with destination and subnetmask. |
R1(config)#ip route 0.0.0.0 0.0.0.0 next hop router |
sets a default route |
|
Day 16 - VLANs (1)
SW1(config-if)#vlan vlan number |
creates the VLAN. |
SW1(config-vlan)name name a vlan |
names the VLAN. |
SW1(config-if)#switchport mode access |
enables the VLAN on the selected interface. |
SW1(config-if)#switchport access vlan vlan number |
lets the configured VLAN number to access the selected interface. |
|
Day 17 - VLANs (2)
SW1(config-if)#switchport mode trunk |
sets the switchport to trunking mode. |
SW1(config-if)#switchport trunk encapsulation dot1q |
manually sets the encapsulation protocol to IEEE 802.1Q |
SW1(config-if)#switchport trunk allowed vlan vlan number |
adds VLANs to the configured/selected trunk |
SW1(config-if)#switchport trunk native vlan native vlan number |
changes the default native VLAN from "1" to the configured native VLAN. |
SW1#show interfaces trunk |
displays the native VLAN number and the allowed VLAN on a trunk |
|
Day 17 - ROAS (3)
R1(config-if)#interface g0/1 |
STEP #1- select a sub-interface. |
R1(config-subif)#encapsulation dot1q vlan id |
STEP #2 - encapsulate the VLAN with IEEE802.1Q frames. |
R1(config-subif)#ip address 192.168.1.62 255.255.255.192 |
STEP #3 - configure the sub-interface with an IP address and subnetmask. |
R1#show ip interface brief |
we can view those sub-interfaces with these commands |
R1#show ip route |
we can view those sub-interfaces with these commands |
|
Day 18 - Multilayer Switch L3
MLSW1(config)#ip routing |
enables Layer 3 routing on the MLSW. |
MLSW1(config-if)#no switchport |
disables L2 switchport and makes it L3 capable switchport. |
|
Day 18 - Multilayer Switch SVI's
SW1(config-if)#interface vlan vlan number* |
STEP 1# select a VLAN to configure an SVI on. |
SW1(config-if)#ip address 192.168.1.62 255.255.255.192 |
STEP 2# set the SVI with an IP address |
SW1(config-if)#no shutdown |
STEP 3# enable the SVI interface. |
|
Day 19 - DTP
SW2(config-if)#switchport mode dynamic auto/desirable |
this is DTP. automatically determining if the switchport needs to be access-access or trunk-trunk. |
SW2(config-if)#switchport nonegotiate |
disables DTP. recommended to disable it for security purposes. *note: switchport mode access also disables DTP, since it's a manual configuration. |
SW2#show interfaces g0/1 switchport |
displays the following; interface name, administrative mode (desirable/auto), operational mode (trunk/access). |
|
Day 19 - VTP
SW1(config)#vtp domain domain name |
changes domain name from "NULL" to a configured domain name. *note: can't delete vtp domain name. only change to a diffreenet VTP domain name or delete the .dat file on the Switch. |
SW1(config)#vtp mode client | server | transparent |
selects one of the following VTP modes |
SW1(config)#vtp version version number 1,2,3 |
selects the version number. *note: for a server switch to share VTP advertisements and copy it's VLANs and revision number and domain name to other client switches. they both need to be set to the same version number. |
SW1#show vtp status |
shows VTP version running, domain name, pruning mode, number of existing VLANs, revision number. |
|
Day 23 - EtherChannel (PAgP / LACP / Static)
MLSW(config)#interface po1 |
#STEP 1 - creates port channel interface |
MLSW(config-if)#switchport trunk encapsulation dot1q |
#STEP 2 - sets the port channel to IEEE 802.1Q VLAN trunking standard |
MLSW(config-if)#switchport mode trunk |
#STEP 3 - sets the port channel to trunk mode |
|
Day 23 - EtherChannel (PAgP / LACP / Static)
SW(config)#interface po1 |
#STEP 1 - creates port channel interface |
SW(config-if)#switchport trunk encapsulation dot1q |
#STEP 2 - sets the port channel to IEEE 802.1Q VLAN trunking standard |
SW(config-if)#switchport mode trunk |
#STEP 3 - sets the port channel to trunk mode |
לערוך עם פאקט טרייסר את הפקודות ^ |
MLSW(config)#interface range g0/1-5 |
STEP #1 - select interfaces |
MLSW(config)#no switchport |
STEP #2 - disable L2 switchport and make switchport L3 capable. |
MLSW(config)#channel-group 1,2,3 mode active / desirable / on* |
STEP #3 - *creates the po1 interface and sets the channel group and EtherChannel Protocol. |
|
|
|
SW1#show etherchannel summary |
displays the flags | (SU) (SD) (RU) etc... |
SW1#show etherchannel load-balance |
displays the load-balance of dst-ip dst-mac-ip etc... |
SW1#show etherchannel port-channel |
לא בטוח שצריך את הפקודה הזו, לבדוק כנגד SUMMARY |
SW1#show ip interface brief |
checks for po1/2/3 interfaces to make sure they've been created.. |
|