Show Menu
Cheatography

Single-Area OSPF Cheat Sheet by

NVS Cheatsheet for Single-Area OSPF

Basic config­uration

Disable DNS lookup
no ip domain­-lookup
Configure device name
hostname [name]
Privileged exec mode password
enable secret [password]
Console password
password [password]
Copy running to startup config
copy r s
These commands were executed on all routers!

Router 1

router ospf 1
enable ospf
network 192.16­8.12.0 0.0.0.3
area 0
configure network statements
show ip ospf neighbor
verify that all routers list all other routers as neighbours
show ip ospf
see process id and router id
show ip ospf interface
detailed list of every OSPF-e­nabled interface
show ip ospf interface g0/0
see specific interface
show ip route ospf
cost for routes
auto-cost refere­nce­s-b­andwith 100
sets the reference bandwith
ip ospf cost 1565
set specific cost
show ip ospf interface brief
verify that ospf is configured
ip ospf priority 255
set interface priority
These are the most important commands for R1 concerning OSPF!
 

Router 2

enable OSPF
router ospf [proce­ss-id]
verify OSPF neighbors
show ip ospf neighbor
routing table
show ip route
verify OSPF protocol settings
show ip protocols
verify OSPF interface settings
show ip ospf interface brief
change router IDs using loopback addresses
interface lo0
ip address 1.1.1.1 255.255.255.255
end
configure G0/0 with OSPF priority 0
interface g0/0
ip ospf priority 100
end
These are the most important commands for R2 concerning OSPF!

Router 3

router ospf 1
enable ospf
network [ip] [subne­tmask] area 0
add network to ospf area
ip ospf priority [number]
set priority to ospf at interface
show ip ospf neighbor
show all devices learned over ospf
clear ip ospf 1 process
reset all the routers of the ospf process
show ip ospf interface
show ospf details
show ip interface brief
show all interfaces
show ip protocols
show all running protocols
These are the most important commands for R3 concerning OSPF!
   
 

Comments

No comments yet. Add yours below!

Add a Comment

Your Comment

Please enter your name.

    Please enter your email address

      Please enter your Comment.

          Related Cheat Sheets

          Push Notifications Cheat Sheet

          More Cheat Sheets by bausac16

          Push Notifications Cheat Sheet
          Mobile Application Cheat Sheet