Show Menu
Cheatography

EtherChannel & VTP Cheat Sheet by

Basic config­uration

no ip domain­-lookup
hostname [hostname]
service passwo­rd-­enc­ryption
banner motd #Unaut­horized access to this device is prohib­ited!#
enable secret class
line console 0
line vty 0 15
password cisco
This is just basic config­uration and has nothing to do with vtp or etherc­hannel

VTP commands

vtp domain [domain]
Set (change) the vtp domain
vtp mode [serve­r|c­lie­nt|­tra­nsp­arent]
Set vtp mode
vtp password [password]
Set vtp password
show vtp status
Verifi­cation command concerning vtp
Show vtp status also shows the revision number of a certain switch.
 

Etherc­hannel

interface range f0/[nu­mbe­r-n­umber]
Enters the interface config­uration mode for a couple interfaces
channe­l-group 1 mode [mode]
Adds the current "­sel­ect­ed" ports to etherc­hannel 1
interface port-c­hannel [number]
Enters the config­uration mode for a specific etherc­hannel
switchport mode trunk
Sets the switchport
switchport trunk native vlan 99
Specifies the port's native VLAN
An etherc­hannel summarizes a few physical cables to one logical cable and speeds up the entire process of data transm­ission -> 4 cables -> 3.9 times faster

DTP commands

interface f0/1
Enters interface config­uration mode for f0/1
switchport mode [mode]
Sets mode
show interfaces trunk
Verifi­cation command concerning dtp
 

Link Aggreg­ation

interface range f0/[nu­mbe­r-n­umber]
Enters the interface config­­ur­ation mode for a couple interfaces
switchport mode trunk
Sets the switchport
switchport trunk native vlan
Specifies the port's native VLAN
channe­l-group [number] mode [mode]
Adds the current "­­se­l­e­ct­­ed" ports to etherc­­hannel 1
Is the same as etherc­hannel, but all devices can use it, so it's not cisco only.

VLAN commands

vlan [number]
Creates vlan with a certain number and automa­tically enters vlan config­uration mode
name [name]
Give the vlan a specific name
show vlan brief
Verify your config­uration
By default all interfaces are in vlan 1
 

Comments

No comments yet. Add yours below!

Add a Comment

Your Comment

Please enter your name.

    Please enter your email address

      Please enter your Comment.

          Related Cheat Sheets

          Single Area OSPF Cheat Sheet
          Single-Area OSPF Cheat Sheet
          Mobile Application Cheat Sheet

          More Cheat Sheets by bausac16

          Push Notifications Cheat Sheet
          Single-Area OSPF Cheat Sheet
          Mobile Application Cheat Sheet